Changes between Version 1 and Version 2 of QtWebKitHacking


Ignore:
Timestamp:
Oct 18, 2011 10:26:43 AM (13 years ago)
Author:
caio.oliveira@openbossa.org
Comment:

File naming conventions

Legend:

Unmodified
Added
Removed
Modified
  • QtWebKitHacking

    v1 v2  
    8787 - SoundQt.cpp - implements systemBeep()  :)
    8888 - Many more classes....
     89
     90== File naming conventions ==
     91
     92We try to stick with these rules for naming the files specific to our port:
     93
     94 - Public API follow Qt conventions: {{{qsomething.cpp}}} {{{qsomething.h}}} with class named {{{QSomething}}}
     95 - Private classes for public API classes follow Qt conventions: {{{qsomething_p.h}}} {{{qsomething_p.cpp}}} (if needed), with class named {{{QSomethingPrivate}}}
     96 - Subclasses and Qt-specific implementations of WebKit/WebCore classes use Qt suffix: {{{FrameLoaderClientQt.cpp}}}
     97 - Other classes created for using in our port use Qt prefix: {{{QtFileDownloader}}}, {{{QtViewInterface}}}