Timeline



Dec 28, 2018:

9:50 PM Changeset in webkit [239558] by Wenson Hsieh
  • 8 edits
    2 adds in trunk/Source/WebKit

Move WKEditCommandObjC and WKEditorUndoTargetObjC into a separate file
https://bugs.webkit.org/show_bug.cgi?id=193049

Reviewed by Sam Weinig.

Pull common code (WKEditCommandObjC and WKEditorUndoTargetObjC) on iOS and macOS out into a separate file. No
change in behavior.

  • SourcesCocoa.txt:
  • UIProcess/Cocoa/WKEditCommand.h: Added.
  • UIProcess/Cocoa/WKEditCommand.mm: Added.

Rename WKEditCommandObjC to WKEditCommand, and WKEditorUndoTargetObjC to WKEditorUndoTarget. The ObjC suffix in
the name seems to diverge from the common naming scheme in other parts of WebKit, where most WK- and _WK-
prefixed names already refer to Objective-C objects. Additionally, mark -[WKEditCommand init] as unavailable.

(-[WKEditCommand initWithWebEditCommandProxy:]):

Make the return type instancetype instead of id, and also make this take a Ref<WebEditCommandProxy>&& instead
of a RefPtr.

(-[WKEditCommand command]):

Make this return a reference to the WebEditCommandProxy, rather than a pointer, since the WebEditCommandProxy
should always be non-null.

(-[WKEditorUndoTarget undoEditing:]):
(-[WKEditorUndoTarget redoEditing:]):

  • UIProcess/Cocoa/WebViewImpl.h:
  • UIProcess/Cocoa/WebViewImpl.mm:

(WebKit::WebViewImpl::WebViewImpl):
(WebKit::WebViewImpl::registerEditCommand):

Use WTFMove instead of copying the Ref when creating a WKEditCommand.

(-[WKEditCommandObjC initWithWebEditCommandProxy:]): Deleted.
(-[WKEditCommandObjC command]): Deleted.
(-[WKEditorUndoTargetObjC undoEditing:]): Deleted.
(-[WKEditorUndoTargetObjC redoEditing:]): Deleted.

  • UIProcess/ios/PageClientImplIOS.h:
  • UIProcess/ios/PageClientImplIOS.mm:

(WebKit::PageClientImpl::PageClientImpl):
(WebKit::PageClientImpl::registerEditCommand):

Use WTFMove instead of creating a new RefPtr when creating a WKEditCommand.

(-[WKEditCommandObjC initWithWebEditCommandProxy:]): Deleted.
(-[WKEditCommandObjC command]): Deleted.
(-[WKEditorUndoTargetObjC undoEditing:]): Deleted.
(-[WKEditorUndoTargetObjC redoEditing:]): Deleted.

  • UIProcess/mac/PageClientImplMac.h:
  • WebKit.xcodeproj/project.pbxproj:
8:24 PM Changeset in webkit [239557] by yusukesuzuki@slowstart.org
  • 9 edits in trunk/Source

[JSC] Remove one indirection in JSObject::toStringName
https://bugs.webkit.org/show_bug.cgi?id=193037

Reviewed by Keith Miller.

Source/JavaScriptCore:

We should not have additional one-level indirection in JSObject::toStringName.
JSObject::toStringName is dispatched through methodTable. Even after that, we
need to call JSObject::className function through methodTable again. But className
function is rarely defined. So instead of introducing this indirection here,
classes having className functions should have toStringName function too. This can
remove one-level indirection in toStringName in major cases.

  • API/JSCallbackObject.h:
  • API/JSCallbackObjectFunctions.h:

(JSC::JSCallbackObject<Parent>::toStringName):

  • debugger/DebuggerScope.cpp:

(JSC::DebuggerScope::toStringName):

  • debugger/DebuggerScope.h:
  • runtime/JSObject.cpp:

(JSC::JSObject::toStringName):

Source/WebCore:

Use old JSObject::toStringName function here.

  • bindings/js/JSDOMConstructorBase.cpp:

(WebCore::JSDOMConstructorBase::className):
(WebCore::JSDOMConstructorBase::toStringName):

  • bindings/js/JSDOMConstructorBase.h:

(WebCore::JSDOMConstructorBase::className): Deleted.

Dec 27, 2018:

8:13 AM Changeset in webkit [239556] by achristensen@apple.com
  • 30 edits
    1 delete in trunk

Resurrect Mac CMake build
https://bugs.webkit.org/show_bug.cgi?id=192658

Reviewed by Yusuke Suzuki.

.:

  • Source/cmake/OptionsMac.cmake:

Source/JavaScriptCore:

  • PlatformMac.cmake:

Source/WebCore:

This makes it so JSC and most of WebCore builds.
WebCore's use of ARC seems inconsistent, so I'll fix that later.

  • PlatformMac.cmake:
  • config.h:

Source/WebCore/PAL:

  • pal/PlatformMac.cmake:

Source/WebKit:

  • PlatformMac.cmake:

Source/WebKitLegacy:

  • PlatformMac.cmake:

Source/WTF:

  • wtf/PlatformMac.cmake:
  • wtf/cf/CFURLExtras.cpp:
  • wtf/cf/CFURLExtras.h:
  • wtf/cf/URLCF.cpp:
  • wtf/cocoa/NSURLExtras.h:
  • wtf/cocoa/NSURLExtras.mm:
  • wtf/cocoa/URLCocoa.mm:

Tools:

  • DumpRenderTree/PlatformMac.cmake:
  • MiniBrowser/mac/CMakeLists.txt:
  • TestWebKitAPI/PlatformMac.cmake:

Dec 26, 2018:

8:01 PM Changeset in webkit [239555] by Fujii Hironori
  • 3 edits in trunk/Source/WebKit

[MSVC] error C2381: 'WebKit::NetworkHTTPSUpgradeChecker::~NetworkHTTPSUpgradeChecker': redefinition; 'declspec(noreturn)' or 'noreturn?' differs
https://bugs.webkit.org/show_bug.cgi?id=193030

Reviewed by Ross Kirsling.

Windows Debug builds are failing to compile due to
NO_RETURN_DUE_TO_ASSERT inconsistency of
NetworkHTTPSUpgradeChecker destructor's definition and
declaration.

  • NetworkProcess/NetworkHTTPSUpgradeChecker.h: Added

NO_RETURN_DUE_TO_ASSERT to NetworkHTTPSUpgradeChecker destructor
declaration.

  • NetworkProcess/NetworkHTTPSUpgradeChecker.cpp: Removed

NO_RETURN_DUE_TO_ASSERT from the definition.

12:42 PM Changeset in webkit [239554] by commit-queue@webkit.org
  • 3 edits in trunk/Source/WebCore

[FreeType] Restore conditional compilation logic for recent HarfBuzz refactoring
https://bugs.webkit.org/show_bug.cgi?id=193036

Patch by Jim Mason <jmason@ibinx.com> on 2018-12-26
Reviewed by Michael Catanzaro.

  • platform/graphics/FontPlatformData.h:
  • platform/graphics/freetype/FontPlatformDataFreeType.cpp:
10:30 AM Changeset in webkit [239553] by Adrian Perez de Castro
  • 6 edits in trunk/Tools

[Tools] Remove references to Bison and Flex
https://bugs.webkit.org/show_bug.cgi?id=193033

Reviewed by Michael Catanzaro.

The Bison and Flex tools are not needed anymore since r209883.

  • CygwinDownloader/cygwin-downloader.py:
  • EWSTools/ubuntu-ews-packages:
  • Scripts/filter-build-webkit:

(shouldIgnoreLine):

  • gtk/install-dependencies:
  • wpe/install-dependencies:

Dec 25, 2018:

11:52 PM Changeset in webkit [239552] by Fujii Hironori
  • 4 edits in trunk/Source/JavaScriptCore

[JSC][Win][Clang] warning: implicit conversion from 'size_t' (aka 'unsigned long long') to 'int32_t' (aka 'int') changes value from 18446744073709551552 to -64 [-Wconstant-conversion]
https://bugs.webkit.org/show_bug.cgi?id=193035

Reviewed by Yusuke Suzuki.

Clang-cl reports a compilation warning for implicit conversion
from -64 size_t to int. Replaced '-maxFrameExtentForSlowPathCall'
with '-static_cast<int32_t>(maxFrameExtentForSlowPathCall)'.

  • dfg/DFGJITCompiler.cpp:

(JSC::DFG::JITCompiler::compile):
(JSC::DFG::JITCompiler::compileFunction):

  • jit/JIT.cpp:

(JSC::JIT::compileWithoutLinking):

  • jit/ThunkGenerators.cpp:

(JSC::slowPathFor):

Note: See TracTimeline for information about the timeline view.