Changes between Version 90 and Version 91 of EFLWebKit


Ignore:
Timestamp:
Jan 10, 2013 2:47:42 AM (9 years ago)
Author:
Christophe Dumez
Comment:

Remove gstreamer from dependencies since it is in jhbuild now and add dependencies needed to build gstreamer

Legend:

Unmodified
Added
Removed
Modified
  • EFLWebKit

    v90 v91  
    6767 * libxt-dev
    6868 * libgl1-mesa-dev
    69  * libgstreamer0.10-dev
    70  * libgstreamer-plugins-base0.10-dev
    7169 * libgnutls-dev (v2.12.14+)
    7270 * libdbus-1-dev
     
    8078 * libxcomposite-dev
    8179 * libatk1.0-dev
     80 * libtheora-dev
     81 * libvorbis-dev
     82 * libfaad-dev
     83 * libpulse-dev
    8284
    83 {{{ sudo apt-get install bison cmake flex gperf gtk-doc-tools libdbus-1-dev libenchant-dev libffi-dev libfreetype6-dev libgl1-mesa-dev libgnutls-dev libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev libicu-dev libjpeg62-dev liblua5.1-0-dev libpng12-dev libsqlite3-dev libtiff4-dev libudev-dev libxslt1-dev libxt-dev ragel ruby subversion libxcomposite-dev libatk1.0-dev }}}
     85{{{ sudo apt-get install bison cmake flex gperf gtk-doc-tools libdbus-1-dev libenchant-dev libffi-dev libfreetype6-dev libgl1-mesa-dev libgnutls-dev libicu-dev libjpeg62-dev liblua5.1-0-dev libpng12-dev libsqlite3-dev libtiff4-dev libudev-dev libxslt1-dev libxt-dev ragel ruby subversion libxcomposite-dev libatk1.0-dev libtheora-dev libvorbis-dev libfaad-dev libpulse-dev }}}
    8486
    8587If for some reason, you're not planning to use the dependencies for the EFL port that are pulled in via jhbuild, please make sure that (after [https://bugs.webkit.org/show_bug.cgi?id=91864 bug 91864 lands] you have an installed version of harfbuzz-ng on your system as well. Unfortunately, it usually doesn't come packaged with your distro, so grab it from http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-0.9.2.tar.bz2 , build and install it manually.