Changes between Version 91 and Version 92 of QtWebKitJournal


Ignore:
Timestamp:
Jun 11, 2010 5:00:53 AM (11 years ago)
Author:
Simon Hausmann
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • QtWebKitJournal

    v91 v92  
    11= 2010 =
     2
     3== Weekly Build Week 22 ==
     4
     5'''DISCLAIMER: These binaries are UNTESTED. Use at your own risk! '''
     6
     7=== Trunk ===
     8
     9This week's binary build from the trunk includes Symbian, Windows/Visual Studio 2008, Mac OS X Linux/X11 (x86). The last commit is SVN revision 60999.
     10
     11  * [http://pepper.troll.no/qtwebkit/weekly-builds/trunk/week23/qtwebkit-trunk-symbian.zip Symbian]
     12  * [http://pepper.troll.no/qtwebkit/weekly-builds/trunk/week23/qtwebkit-trunk-linux-g++-32.tgz Linux/X11 x86]
     13  * [http://pepper.troll.no/qtwebkit/weekly-builds/trunk/week23/qtwebkit-trunk-win32-msvc2008.zip Windows/Visual Studio 2008]
     14  * [http://pepper.troll.no/qtwebkit/weekly-builds/trunk/week23/qtwebkit-trunk-macx-g++-cocoa.tgz Mac OS X]
     15  * [http://pepper.troll.no/qtwebkit/weekly-builds/trunk/week23/qtwebkit-trunk-source.tar.gz Sources]
     16
     17Known issues:
     18
     19  * You need to have Qt 4.6 installed on your system and set your PATH/LD_LIBRARY_PATH accordingly, so that QtLauncher can find the Qt libraries.
     20  * Due to internal build issues there's no Maemo 5 build this week.
     21  * On Mac OS X, you need to have the _Cocoa_ build of Qt installed. It's not necessary to set any library path variables. Start QtLauncher on the command line, not in Finder.
     22
     23== 2.0 Release Branch ==
     24
     25This week's binary build from the 2.0 release branch includes Symbian, Windows/Visual Studio 2008, Mac OS X and Linux/X11 (x86). The last commit is f3dc6deef5a85d6c7ae13c6c7b37e7da50e20233 .
     26
     27  * [http://pepper.troll.no/qtwebkit/weekly-builds/2.0/week23/qtwebkit-2.0-symbian.zip Symbian]
     28  * [http://pepper.troll.no/qtwebkit/weekly-builds/2.0/week23/qtwebkit-2.0-linux-g++-32.tgz Linux/X11 x86]
     29  * [http://pepper.troll.no/qtwebkit/weekly-builds/2.0/week23/qtwebkit-2.0-win32-msvc2008.zip Windows/Visual Studio 2008]
     30  * [http://pepper.troll.no/qtwebkit/weekly-builds/2.0/week23/qtwebkit-2.0-macx-g++-cocoa.tgz Mac OS X]
     31  * [http://pepper.troll.no/qtwebkit/weekly-builds/2.0/week23/qtwebkit-2.0-source.tar.gz Sources]
     32
     33Known issues:
     34
     35  * You need to have Qt 4.6 installed on your system and set your PATH/LD_LIBRARY_PATH accordingly, so that QtLauncher can find the Qt libraries.
     36  * On Mac OS X, you need to have the _Cocoa_ build of Qt installed. It's not necessary to set any library path variables. Start QtLauncher on the command line, not in Finder.
     37  * Due to internal build issues there's no Maemo 5 build this week.
     38
     39Bug fixes integrated since week 22:
     40
     41|| <https://webkit.org/b/40359> || [Qt] Imperfect dependency for generated SVGNames.cpp ||
     42|| <https://webkit.org/b/31403> || [Qt] Disable pthread_setname_np. ||
     43|| <https://webkit.org/b/39357> || [QT] QT_BEARER flag is not enabled on S60 properly ||
     44|| <https://webkit.org/b/40401> || REGRESSION: [Qt] When dragging onto a page that handles the drag in Javascript it will be a move and not a copy by default ||
     45|| <https://webkit.org/b/38324> || [Qt] Fix compilation with QT_NO_FEATURE ||
     46|| <https://webkit.org/b/39958> || [Qt] TextBreakIteratorQt performance ||
     47|| <https://webkit.org/b/40116> || [Qt] Compilation fails when compiling against Qt 4.7 and Qt Mobility is installed ||
     48|| <https://webkit.org/b/40221> || REGRESSION(r60169): [Qt] Selected text is not drawn with the correct color. ||
     49
    250
    351== Weekly Build Week 22 ==