Changes between Version 3 and Version 4 of WebKitGTK/Dependencies


Ignore:
Timestamp:
Mar 22, 2015 6:11:47 PM (7 years ago)
Author:
Michael Catanzaro
Comment:

Add license warning for gnutls, since LGPLv3+ patent giveaway is unacceptable to many companies

Legend:

Unmodified
Added
Removed
Modified
  • WebKitGTK/Dependencies

    v3 v4  
    2121|| libsoup || Networking library || Yes || 2.42.0 || >= 2.49.1.1 || ||
    2222|| sqlite || SQLite library || Yes || - || - || ||
    23 || gnutls || Secure communications library || No || 3.0.0 || >= 3.3.x || Not required but strongly recommended. Indirectly required if you use glib-networking. ||
     23|| gnutls || Secure communications library || No || 3.0.0 || >= 3.3.x || Strongly recommended. Indirectly required if you use glib-networking. Distributors should consider the license obligations ||
    2424|| gstreamer || Multimedia library || No || 1.0.3 || >= 1.2.0 || Required by default, use -DENABLE_VIDEO=OFF -DENABLE_WEB_AUDIO=OFF to build without GStreamer  ||
    2525|| LibX11 || X11 library || No || - || - || Required by default, use -DENABLE_X11_TARGET=OFF -DENABLE_WAYLAND_TARGET=ON ||