Changes between Version 9 and Version 10 of WebKitGTK/GCCRequirement


Ignore:
Timestamp:
Jul 4, 2019 9:10:42 AM (16 months ago)
Author:
Michael Catanzaro
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WebKitGTK/GCCRequirement

    v9 v10  
    1111 * (GCC 7 OR Clang 6) AND libstdc++ 7, the versions in Ubuntu 18.04, will be supported until April 2021
    1212 * (GCC 8 OR Clang 7) AND libstdc++ 8, the versions in Debian Buster, will be supported until, roughly, late 2022
     13
     14This policy affects trunk, so the first stable branch to require the new dependencies would be later than that date:
     15
     16 * WebKitGTK or WPE WebKit 2.24 (released March 2019) support GCC 6
     17 * WebKitGTK or WPE WebKit 2.26 (scheduled for September 2019) will be the first release to require GCC 7
     18 * The first release to require libstdc++ 8 should be WebKitGTK or WPE WebKit 2.34 (scheduled for September 2021).
     19 * The first release to require libstdc++ 9 should be WebKitGTK or WPE WebKit 2.38 (scheduled for September 2022) or 2.40 (scheduled for March 2023).