Changes between Version 1 and Version 2 of WebKitGTK/GCCRequirement


Ignore:
Timestamp:
Nov 20, 2017 8:26:28 AM (5 years ago)
Author:
Michael Catanzaro
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WebKitGTK/GCCRequirement

    v1 v2  
    1 WebKit is a complex C++ program that often requires relatively new versions of GCC to build. Older versions of GCC tend to have bugs that prevent code from compiling successfully, which tend to be fixed in newer versions of GCC, and which are often encountered in practice by WebKit developers. Apple also likes to be able to use new C++ features, which are often not present in older versions of GCC, relatively early. Because Apple does not use GCC to develop WebKit, and because of the relatively high number of compatibility issues caused by supporting GCC, we should be grateful that it is still possible to build WebKit with GCC at all.
     1WebKit is a complex C++ program that often requires relatively new versions of GCC to build. Older versions of GCC tend to have bugs that prevent code from compiling successfully, which tend to be fixed in newer versions of GCC, and which are often encountered in practice by WebKit developers. Apple also likes to be able to use new C++ features, which are often not present in older versions of GCC, relatively early.
    22
    33We are aware that Linux distributions and embedded systems vendors like to be able to compile everything with the same version of GCC, which may be very old, so we have compromised with Apple to develop a [[DependenciesPolicy]] that attempts to balance the interests of both WebKit users and developers. With respect to GCC, we intend to support the version of GCC in the latest Ubuntu LTS and Debian stable releases. As of fall 2017, that is Ubuntu 16.04 (GCC 5) and Debian Stretch (GCC 6). We'll continue to support GCC 5 at least until the release of Ubuntu 18.04 in April 2018. Shortly thereafter, you should expect that an upgrade to GCC 6 will be required to build trunk. Accordingly, the 2.22 releases of WebKitGTK+ and WPE will likely be the first to require GCC 6. After that, GCC 6 will be supported at least until the next Debian stable release. While we can't be sure when the next Debian stable release will be, it will probably be in mid to late 2019, so it is likely that either the 2.26 or 2.28 release will be the first to require GCC 7.
    44
    5 Unless you are able to upgrade your systems to newer GCCs on a regular basis, it is expected that your system GCC may not be new enough to build WebKit. We urge you to consider building with a custom compiler instead. One option that may sometimes work is to try to build with Clang, which may be new enough when GCC is not. (Clang is the compiler that Apple uses to develop WebKit.) Another option is to bootstrap a newer version of GCC as part of your WebKit build. If you choose to stop building new versions of WebKit as a result of a GCC version increase, rather than bootstrapping a newer compiler, your users will be left vulnerable to numerous security vulnerabilities that are fixed in newer versions.
     5This policy may mean that a new version of GCC is required sooner than you might prefer. Because Apple does not use GCC to develop WebKit, and because of the relatively high number of compatibility issues caused by supporting GCC, we should be grateful that it is still possible to build WebKit with GCC at all. Unless you are able to upgrade your systems to newer GCCs on a regular basis, it is expected that your system GCC may not be new enough to build WebKit. We urge you to consider building with a custom compiler instead. One option that may sometimes work is to try to build with Clang, which may be new enough when GCC is not. (Clang is the compiler that Apple uses to develop WebKit.) Another option is to bootstrap a newer version of GCC as part of your WebKit build. If you choose to stop building new versions of WebKit as a result of a GCC version increase, rather than bootstrapping a newer compiler, your users will be left vulnerable to numerous security vulnerabilities that are fixed in newer versions.