Changes between Version 2 and Version 3 of WebKitGTK/GCCRequirement


Ignore:
Timestamp:
Nov 20, 2017 8:26:40 AM (5 years ago)
Author:
Michael Catanzaro
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WebKitGTK/GCCRequirement

    v2 v3  
    1 WebKit is a complex C++ program that often requires relatively new versions of GCC to build. Older versions of GCC tend to have bugs that prevent code from compiling successfully, which tend to be fixed in newer versions of GCC, and which are often encountered in practice by WebKit developers. Apple also likes to be able to use new C++ features, which are often not present in older versions of GCC, relatively early.
     1WebKit is a complex C++ library that often requires relatively new versions of GCC to build. Older versions of GCC tend to have bugs that prevent code from compiling successfully, which tend to be fixed in newer versions of GCC, and which are often encountered in practice by WebKit developers. Apple also likes to be able to use new C++ features, which are often not present in older versions of GCC, relatively early.
    22
    33We are aware that Linux distributions and embedded systems vendors like to be able to compile everything with the same version of GCC, which may be very old, so we have compromised with Apple to develop a [[DependenciesPolicy]] that attempts to balance the interests of both WebKit users and developers. With respect to GCC, we intend to support the version of GCC in the latest Ubuntu LTS and Debian stable releases. As of fall 2017, that is Ubuntu 16.04 (GCC 5) and Debian Stretch (GCC 6). We'll continue to support GCC 5 at least until the release of Ubuntu 18.04 in April 2018. Shortly thereafter, you should expect that an upgrade to GCC 6 will be required to build trunk. Accordingly, the 2.22 releases of WebKitGTK+ and WPE will likely be the first to require GCC 6. After that, GCC 6 will be supported at least until the next Debian stable release. While we can't be sure when the next Debian stable release will be, it will probably be in mid to late 2019, so it is likely that either the 2.26 or 2.28 release will be the first to require GCC 7.