wiki:WebKitGTK/DependenciesPolicy

Our dependencies policy is simple:

  • We support each major Debian version until one year after the release of the next major version.
  • We support each Ubuntu LTS until one year after the release of the next Ubuntu LTS.

During the support period, we intend for WebKit to remain buildable on these distributions using some system-provided compiler -- not necessarily the default system compiler -- and with the default system libstdc++. The purpose of this policy is to ensure distributions can provide updated versions of WebKit during the support period to ensure users receive security updates.

For more information, see GCCRequirement.

Last modified 6 weeks ago Last modified on May 7, 2019 6:38:48 AM