Changes between Version 6 and Version 7 of WebInspectorCodingStyleGuide


Ignore:
Timestamp:
Dec 2, 2013 2:06:55 PM (8 years ago)
Author:
timothy@apple.com
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WebInspectorCodingStyleGuide

    v6 v7  
    1414    });
    1515}}}
    16 * Avoid using the "on" prefix where possible. The `_onFoo` methods can just be `_foo`.
     16* Avoid using the "on" prefix where possible. The `_onFoo` methods can just be `_foo` or `_handleFoo`.
    1717* New class names should use the name of the base class as a suffix. (ex: `TimelinesContentView` < `ContentView`). Exceptions: classes extending `WebInspector.Object` (unless they are a represented object), and deep hierarchies such as `DebuggerSidebarPanel` < `NavigationSidebarPanel` < `SidebarPanel` < `Object`.
    1818* Add new lines before and after different tasks performed in the same function.
     
    2727{
    2828    WebInspector.Object.call(this);
     29
    2930    this._propertyName = ...;
    3031}
     
    5758
    5859    // Protected
     60
    5961    handleEvent: function(event)
    6062    {